EduMandriva

форум российского сообщества Edumandriva

Форум предназначен для обсуждения вопросов проекта Edumandriva. По вопросам дистрибутивов Mandriva и РОСА просьба обращаться на forum.rosalab.ru, unixforum.org и linuxforum.ru

Текущее время: 27 фев 2020 22:24

Часовой пояс: UTC + 3 часа [ Летнее время ]




Начать новую тему Эта тема закрыта, вы не можете редактировать и оставлять сообщения в ней.  [ Сообщений: 9 ] 
Автор Сообщение
 Заголовок сообщения: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 15:44 

Зарегистрирован: 19 янв 2012 14:53
Сообщения: 4
Привет всем!
Использую в основном дистрибутивы линукс с пакетным менеджером apt на основе дебиан.
Но пришлось столкнуться с мадривой. Слышал что для мадривы есть пакет apt, но он у меня не
устанавливается. Требует какие -то зависимости.
Как установить этот пакет?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 15:55 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
В мандриве используется urpmi.
http://ru.wikipedia.org/wiki/Urpmi


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 16:06 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
А вообще пакет apt находится в официальном репозитории contrib
Подключать репозитории тут: http://urpmi.mandriva.ru/
Ставить так:
Код:
su
urpmi apt


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 16:23 

Зарегистрирован: 19 янв 2012 14:53
Сообщения: 4
Я эти команды вводил
su
urpmi apt
На это мадрива ругается что не может удовлетворить какие-то свои только ей известные
зависимости. не могу поставить пакет libapt-pkg4-0.5.15lorg3.94-lmdv2011.0-i586 (из-за неудовлетворенности libjsoncpp.so) Где искать эту его неудовлетворенность не понимаю.
А нет ли чего нибудь как в дебиане?
Что делать дальше?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 16:42 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
Цитата:
Где искать эту его неудовлетворенность не понимаю.

В репах должна быть: http://pkgs.org/mandriva-2011/mandriva- ... 6.rpm.html
Цитата:
А нет ли чего нибудь как в дебиане?

http://ru.wikipedia.org/wiki/PCLinuxOS
Цитата:
Что делать дальше?

Использовать urpmi, на которую и репозитории завязаны.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 18:11 

Зарегистрирован: 19 янв 2012 14:53
Сообщения: 4
вы мне конкретно скажите какие команды ввести что бы этот пакет установить.
Я вроде бы подцепил все репозитарии какие есть, но это не помогает.
Скажите как подключить репозитарий и установить apt с этой зависимостью.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 18:16 

Зарегистрирован: 06 мар 2010 14:55
Сообщения: 2696
Пакет называется libjsoncpp0. Какие-то косяки у него с провайдсами...
А с чего Вы взяли, что так запросто сможете apt использовать в Мандриве?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 18:29 

Зарегистрирован: 19 янв 2012 14:53
Сообщения: 4
Я уже понял что проще изучить urpmi чем установить apt.
Я просто наивно думал что на мадриву можно легко поставить apt.
Я libjsoncpp0 попытался установить, но это потянуло за собой еще другие зависимости.
И опять возвращаемся  к исходному вопросу.
Есть ли утилита типа apt, которая автоматом удовлетворяет все зависимости.
Так как urpmi сама похоже не умеет удовлетворять все зависимости в отличии от apt.
Я даже готов изучить ее, но дайте такую же удобную утилиту.
Ну не хочется мне самому в ручную удовлетворять все зависимости.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблемы с установкой пакета apt
СообщениеДобавлено: 19 янв 2012 18:55 
Аватара пользователя

Зарегистрирован: 20 апр 2010 18:22
Сообщения: 826
Читаем внимательно мелкий шрифт в шапке, вникаем. Apt в Мандриве НЕ ПОДДЕРЖИВАЕТСЯ. В Мандриве urpmi или голый rpm. Тему закрываю.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Эта тема закрыта, вы не можете редактировать и оставлять сообщения в ней.  [ Сообщений: 9 ] 

Часовой пояс: UTC + 3 часа [ Летнее время ]


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB