EduMandriva

форум российского сообщества Edumandriva

Форум предназначен для обсуждения вопросов проекта Edumandriva. По вопросам дистрибутивов Mandriva и РОСА просьба обращаться на forum.rosalab.ru, unixforum.org и linuxforum.ru

Текущее время: 22 сен 2020 12:50

Часовой пояс: UTC + 3 часа [ Летнее время ]




Начать новую тему Ответить на тему  [ Сообщений: 4 ] 
Автор Сообщение
 Заголовок сообщения: urpmi при установке меняет местами пакеты и выдает ошибку
СообщениеДобавлено: 01 апр 2012 15:58 

Зарегистрирован: 01 апр 2012 15:44
Сообщения: 2
Сначала был установлен пакет apache-mpm-event-2.2.22-0.1-mdv2011.0.x86_64.
После установки других пакетов, то  apache-mpm-event-2.2.22-0.1-mdv2011.0.x86_64 был удалён.
При удаление полностью apache-base и установки apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64.rpm, то устанавить больше не получилось внизу логи.
[Показать] Скрытый текст:
Код:
Для удовлетворения зависимостей будут установлены следующие пакеты:
   Пакет                          Версия       Релиз         Платформа
(источник «Main Updates»)
  apache-base                    2.2.22       0.1 x86_64  
  apache-modules                 2.2.22       0.1 x86_64  
  apache-mpm-prefork             2.2.22       0.1 x86_64  
Будет использовано 1.8МБ дополнительного дискового пространства.
Установить 3 пакетов? (Y/n) y


устанавливается apache-base-2.2.22-0.1-mdv2011.0.x86_64.rpm apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64.rpm apache-modules-2.2.22-0.1-mdv2011.0.x86_64.rpm из /var/cache/urpmi/rpms
Установка не удалась:   apache-base = 2.2.22-0.1 нужен для apache-mpm-prefork-2.2.22-0.1.x86_64
        apache-modules = 2.2.22-0.1 нужен для apache-mpm-prefork-2.2.22-0.1.x86_64

В табице список последовательно показывает правильно, а когда ставит, то меняет местами apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64.rpm с apache-modules-2.2.22-0.1-mdv2011.0.x86_64.rpm.

все пакеты в папке /var/cache/urpmi/rpms/ присутствуют.

Как исправить эти перевёрты?


Последний раз редактировалось x-rayboy 01 апр 2012 16:18, всего редактировалось 1 раз.

Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: urpmi при установке меняет местами пакеты и выдает ошибк
СообщениеДобавлено: 01 апр 2012 16:04 

Зарегистрирован: 06 мар 2010 14:55
Сообщения: 2696
Добавьте к команде, которой ставили, --debug и покажите весь вывод полностью (и заодно саму команду не забудьте).


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: urpmi при установке меняет местами пакеты и выдает ошибк
СообщениеДобавлено: 01 апр 2012 16:12 

Зарегистрирован: 01 апр 2012 15:44
Сообщения: 2
bizdelnick писал(а):
Добавьте к команде, которой ставили, --debug и покажите весь вывод полностью (и заодно саму команду не забудьте).

[Показать] Скрытый текст: Логи
Код:
# urpmi apache-mpm-prefork --debug
getting lock on urpmi
parsing: /etc/urpmi/mediacfg.d/Cooker-2011.0-x86_64
loading mirrors cache
using mirror http://ftp.funet.fi/pub/mirrors/mandriva.com/official/2011/x86_64
using mirror http://ftp.funet.fi/pub/mirrors/mandriva.com/official/2011/x86_64
using mirror http://ftp.funet.fi/pub/mirrors/mandriva.com/official/2011/x86_64
using mirror http://ftp.funet.fi/pub/mirrors/mandriva.com/official/2011/x86_64
изучается файл synthesis [/var/lib/urpmi/Main/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/Main Updates/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/Contrib/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/Contrib Updates/synthesis.hdlist.cz]
getting exclusive lock on rpm
search_packages: found apache-mpm-prefork-2.2.19-1-mdv2011.0.x86_64 matching apache-mpm-prefork
search_packages: found apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64 matching apache-mpm-prefork
found package(s): apache-mpm-prefork-2.2.19-1-mdv2011.0.x86_64 apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64
opening rpmdb (root=, write=)
chosen apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64 for apache-mpm-prefork|apache-mpm-prefork
selecting apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64
requiring apache-base[*][== 2.2.22-0.1],apache-modules[*][== 2.2.22-0.1] for apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64
chosen apache-base-2.2.22-0.1-mdv2011.0.x86_64 for apache-base[*][== 2.2.22-0.1]
selecting apache-base-2.2.22-0.1-mdv2011.0.x86_64
chosen apache-modules-2.2.22-0.1-mdv2011.0.x86_64 for apache-modules[*][== 2.2.22-0.1]
selecting apache-modules-2.2.22-0.1-mdv2011.0.x86_64
apache-mpm-prefork is not in potential orphans
no filesize for package apache-base-2.2.22-0.1-mdv2011.0.x86_64
Для удовлетворения зависимостей будут установлены следующие пакеты:
   Пакет                          Версия       Релиз         Платформа
(источник «Main Updates»)
  apache-base                    2.2.22       0.1 x86_64  
  apache-modules                 2.2.22       0.1 x86_64  
  apache-mpm-prefork             2.2.22       0.1 x86_64  
Будет использовано 1.8МБ дополнительного дискового пространства.
Установить 3 пакетов? (Y/n) y
opening rpmdb (root=, write=)
getting graph of dependencies for sorting
sorting graph of dependencies
rpms sorted by dependencies:
apache-mpm-prefork+apache-base+apache-modules
selecting apache-base-2.2.22-0.1-mdv2011.0.x86_64
requiring apache[== 2.2.22-0.1] for apache-base-2.2.22-0.1-mdv2011.0.x86_64
chosen apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64 for apache[== 2.2.22-0.1]
selecting apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64
requiring apache-modules[*][== 2.2.22-0.1] for apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64
chosen apache-modules-2.2.22-0.1-mdv2011.0.x86_64 for apache-modules[*][== 2.2.22-0.1]
selecting apache-modules-2.2.22-0.1-mdv2011.0.x86_64
transaction valid: remove= update=apache-base,apache-mpm-prefork,apache-modules
scheduled sets of transactions:
remove=0= update=3=apache-base,apache-mpm-prefork,apache-modules


verifying signature of /var/cache/urpmi/rpms/apache-base-2.2.22-0.1-mdv2011.0.x86_64.rpm
verifying signature of /var/cache/urpmi/rpms/apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64.rpm
verifying signature of /var/cache/urpmi/rpms/apache-modules-2.2.22-0.1-mdv2011.0.x86_64.rpm
устанавливается apache-base-2.2.22-0.1-mdv2011.0.x86_64.rpm apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64.rpm apache-modules-2.2.22-0.1-mdv2011.0.x86_64.rpm из /var/cache/urpmi/rpms
starting installing packages
opening rpmdb (root=, write=1)
создана транзакция для установки на / (remove=0, install=0, upgrade=3)
trans: scheduling update of apache-base-2.2.22-0.1-mdv2011.0.x86_64 (id=8941, file=/var/cache/urpmi/rpms/apache-base-2.2.22-0.1-mdv2011.0.x86_64.rpm)
trans: scheduling update of apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64 (id=8938, file=/var/cache/urpmi/rpms/apache-mpm-prefork-2.2.22-0.1-mdv2011.0.x86_64.rpm)
trans: scheduling update of apache-modules-2.2.22-0.1-mdv2011.0.x86_64 (id=8949, file=/var/cache/urpmi/rpms/apache-modules-2.2.22-0.1-mdv2011.0.x86_64.rpm)
Установка не удалась:
        apache-base = 2.2.22-0.1 нужен для apache-mpm-prefork-2.2.22-0.1.x86_64
        apache-modules = 2.2.22-0.1 нужен для apache-mpm-prefork-2.2.22-0.1.x86_64

Установка не удалась:   apache-base = 2.2.22-0.1 нужен для apache-mpm-prefork-2.2.22-0.1.x86_64
        apache-modules = 2.2.22-0.1 нужен для apache-mpm-prefork-2.2.22-0.1.x86_64
unlocking urpmi database
unlocking rpm database
EXITING (pid=6529)


Ешё хочу добавить, что была установлена версия 2010.2, а при предложении обновить до 2011.0 я сменил место закачки файлов на предложенный из вариантов "Загрузки", но программа не справилась с путём на кирилице и выдавала ошибки при обращении к директории. Но система хоть и не обновилась на практике, зато теперь предлагает пакеты 2011. Как откатить эту муть? Тем более, программа обновления всё время "находит" обновление, но при открывании окна обновления список пустой. Как я понял обновление предлагается для 2011 которой фактически нет.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: urpmi при установке меняет местами пакеты и выдает ошибк
СообщениеДобавлено: 02 апр 2012 09:34 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
x-rayboy,
Первая ошибка была - обновление с 2010.2 до 2011.0 (обновление кривое и крайне не рекомендуется - вы это уже поняли) - только чистая установка
Вторую проблему решить легко: просто удалите все источники обновлений
Код:
# urpmi.removemedia -a

и добавьте нужные заново.

з.ы. думается система уже превращена в помойку (легкое решение всё переустановить)


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 4 ] 

Часовой пояс: UTC + 3 часа [ Летнее время ]


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB