EduMandriva

форум российского сообщества Edumandriva

Форум предназначен для обсуждения вопросов проекта Edumandriva. По вопросам дистрибутивов Mandriva и РОСА просьба обращаться на forum.rosalab.ru, unixforum.org и linuxforum.ru

Текущее время: 29 мар 2020 09:35

Часовой пояс: UTC + 3 часа [ Летнее время ]




Начать новую тему Ответить на тему  [ Сообщений: 35 ]  На страницу Пред.  1, 2, 3, 4  След.
Автор Сообщение
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 21 фев 2011 10:58 

Зарегистрирован: 08 июл 2010 19:59
Сообщения: 26
Сменил на curl, вот что пишет...

Не удаётся добавить источник. Ошибки:

...извлечение не удалось: сбой curl: завершён с 1
нет доступа к источнику с дистрибутивом (не найден файл media.cfg)

Источник:Official2010.2- ()


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 21 фев 2011 12:53 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
Пробуйте из консоли:
Код:
su
urpmi.removemedia -a
urpmi.addmedia --distrib --wget http://ftp-stud.fht-esslingen.de/pub/Mirrors/Mandrakelinux/official/2010.2/i586/

После отмечаем в менеджере нужные источники (non-free, backports по желанию, не трогая testing и debug)
Далее на http://urpmi.mandriva.ru/ добавляем PLF(так же в менеджере non-free, backports по желанию, не трогая testing и debug) и Edumandriva

з.ы. проверил самолично; всё добавляется нормально


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 22 фев 2011 12:49 

Зарегистрирован: 14 фев 2011 22:38
Сообщения: 30
ОФФрепы восстановили!

_________________
KDE_4.6.5_kernel-desktop-3.1.6-mib


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 14 ноя 2011 12:37 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
Ошибки при обновлении:
[Показать] Скрытый текст:
Код:
To satisfy dependencies, the following packages are going to be installed:
Package                        Version      Release       Dist  DEpoch Arch
(medium ""2011(EDM)-repo" (edumandriva1)")
mandriva-theme-Free            1.4.9        11            mdv   2011.0 noarch
mandriva-theme-Free-screensav> 1.4.9        11            mdv   2011.0 noarch
mandriva-theme-common          1.4.9        11            mdv   2011.0 noarch
1.3MB of additional disk space will be used.
7.5MB of packages will be retrieved.
Proceed with the installation of the 3 packages? (Y/n) y


    ftp://ftp.mandriva.ru/EduMandriva/educontrib/2011.0/i586/media/free/mandriva-theme-Free-1.4.9-11-mdv2011.0.noarch.rpm
    ftp://ftp.mandriva.ru/EduMandriva/educontrib/2011.0/i586/media/free/mandriva-theme-Free-screensaver-1.4.9-11-mdv2011.0.noarch.rpm       
    ftp://ftp.mandriva.ru/EduMandriva/educontrib/2011.0/i586/media/free/mandriva-theme-common-1.4.9-11-mdv2011.0.noarch.rpm                 
installing mandriva-theme-Free-screensaver-1.4.9-11-mdv2011.0.noarch.rpm mandriva-theme-Free-1.4.9-11-mdv2011.0.noarch.rpm mandriva-theme-common-1.4.9-11-mdv2011.0.noarch.rpm from /var/cache/urpmi/rpms
Preparing...                     ##########################################################################################################
Installation failed:
        file /usr/share/mdk/screensaver/land-01.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-02.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-03.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-04.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-05.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-06.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-07.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch

Installation failed:    file /usr/share/mdk/screensaver/land-01.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-02.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-03.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-04.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-05.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-06.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
        file /usr/share/mdk/screensaver/land-07.jpg from install of mandriva-theme-Free-screensaver-1.4.9-11.noarch conflicts with file from package mandriva-theme-Rosa-screensaver-1.4.9-9.noarch
[verg@localhost ~]$

[verg@localhost ~]$ rpm -qa | grep mandriva
[Показать] Скрытый текст:
Код:
rpm-mandriva-setup-1.130-1-mdv2011.0.i586
mandriva-kde-icons-1.0.4-13-mdv2011.0.noarch
mandriva-doc-common-2010.1-1.1-mdv2011.0.noarch
mandriva-gfxboot-theme-4.1.19.25-2-mdv2011.0.i586
mandriva-theme-Free-screensaver-1.4.9-9-mdv2011.0.noarch
mandriva-theme-Free-1.4.9-9-mdv2011.0.noarch
mandriva-release-Free-2011.0-2-mdv2011.0.i586
mandriva-release-common-2011.0-2-mdv2011.0.i586
mandriva-kde-translation-2011-6-mdv2011.0.noarch
mandriva-kde4-config-common-2011-1-mdv2011.0.noarch
mandriva-theme-Rosa-screensaver-1.4.9-9-mdv2011.0.noarch
mandriva-theme-Rosa-1.4.9-9-mdv2011.0.noarch
mandriva-kde3-config-common-2011.0-5-mib2011.0.noarch
rpm-mandriva-setup-build-1.130-1-mdv2011.0.i586
mandriva-theme-common-1.4.9-10-mdv2011.0.noarch
[verg@localhost ~]$


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 14 ноя 2011 15:55 
Аватара пользователя

Зарегистрирован: 20 апр 2010 18:22
Сообщения: 826
Сейчас поправим - по ошибке ушли темы Free и One в репы - так то добавилась только EDM тема.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 14 ноя 2011 21:15 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
Исправлено!


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 28 дек 2011 19:23 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
Эти пакеты были удалены из репозитория edu: (с основного фтп) - на зеркалах пока ещё есть (Интересно какие ещё?)
Цитата:
rpm
rpm-build
python-rpm
rpm-apidocs
librpm5.3



Но всё еще предлагаются для обновления! При этом они физически отсутствуют.

Код:
Для удовлетворения зависимостей будет установлен следующий пакет:
Пакет                          Версия       Релиз         Dist  DEpoch Платформа
(источник «edumandriva-free»)
python-rpm                     5.3.12       0.20110807.3  mdv   2011.0 i586
Будет использовано 0Б дополнительного дискового пространства.
Будет загружено 141КБ пакетов.
Установить один пакет? (Y/n) y


    ftp://ftp.mandriva.ru/EduMandriva/educontrib/2011.0/i586/media/free/python-rpm-5.3.12-0.20110807.3-mdv2011.0.i586.rpm

...извлечение не удалось: curl: (19) Given file does not exist
...извлечение не удалось: сбой curl: завершён с 19

Установка не удалась, отсутствуют некоторые файлы:
    ftp://ftp.mandriva.ru/EduMandriva/educontrib/2011.0/i586/media/free/python-rpm-5.3.12-0.20110807.3-mdv2011.0.i586.rpm
Возможно, необходимо обновить базу данных urpmi

Попробовать в любом случае? (y/N)

Так же похоже нужно переустанавливать эти пакеты.

Исправлено!


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 30 дек 2011 05:25 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
Если подключить к основным репам только:
/2011/eduamndriva_free
/2011/eduamndriva_non-free

и не подключать /2011/edumandriva_kernel, то получится вот такая коллизия:
Код:
[verg@localhost ~]$ rpm -qa | grep kernel-firmware
kernel-firmware-20110314-2-mdv2011.0.noarch
kernel-firmware-extra-20110428-1-mdv2011.0.noarch
[verg@localhost ~]$ urpmf -mf kernel-firmware
kernel-firmware-20110314-2-mdv2011.0.noarch:Main (Official2011.0-1)
kernel-firmware-extra-20110125-1-mdv2011.0.noarch:Non-free (Official2011.0-17)
kernel-firmware-extra-20101220-1mnb2.noarch:Non-free (Official2011.0-17)
kernel-firmware-extra-20110310-2-mdv2011.0.noarch:Non-free (Official2011.0-17)
kernel-firmware-extra-20110428-1-mdv2011.0.noarch:Non-free (Official2011.0-17)
kernel-firmware-extra-20110817-1-mdv2011.0.noarch:edumandriva_non-free


И сама ошибка:
Код:
[verg@localhost ~]$ urpmi --auto-select --auto-update
Следующий пакет будет удалён для обновления остальных:
kernel-firmware-20110314-2-mdv2011.0.noarch
(из-за конфликтов с kernel-firmware-extra-20110817-1-mdv2011.0.noarch) (y/N) y
Для удовлетворения зависимостей будут установлены следующие пакеты:
Пакет                          Версия       Релиз         Dist  DEpoch Платформа
(источник «edumandriva_free»)
elementary-icons               2.7.1        5             mdv   2011.0 noarch
fonts-ttf-ubuntu               0.80         1             mdv   2011.0 noarch
kde-l10n-ru                    4.6.5        3             mdv   2011.0 noarch
libbluez3                      4.96         1             mdv   2011.0 i586
mandriva-theme-common          1.4.9        11            mdv   2011.0 noarch
mandriva-theme-extra           1.4.9        11            mdv   2011.0 noarch
(источник «edumandriva_non-free»)
kernel-firmware-extra          20110817     1             mdv   2011.0 noarch
Будет использовано 14МБ дополнительного дискового пространства.
Будет загружено 144МБ пакетов.
Установить 7 пакетов? (Y/n) n



Исправлено!


Последний раз редактировалось verg 31 дек 2011 02:27, всего редактировалось 1 раз.

Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 30 дек 2011 05:29 
Аватара пользователя

Зарегистрирован: 07 окт 2010 03:30
Сообщения: 1482
В репе /rolling этой проблемы нет. (правда там в репе фри и нонфри пакет кернел-фирмваре-экстра присутствует)

Кстати непонятно зачем много пакетов в этот самый роллинг перетекло, когда они нужны в основных (drakxtools и т.п.)
(придется кучу постов в интернетах искать/исправлять, где советовал эти инструменты обновлять , альтернативы то нету )

Предложение по репе: драйвера nvidia перенести из /kernel в /non-free


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с Репозиториями и Обновлениями!
СообщениеДобавлено: 25 июл 2012 16:50 

Зарегистрирован: 19 окт 2010 14:51
Сообщения: 105
Сегодня (25.07.12) в обновлениях приехал firefox 14.0.1 без пакета firefox-ru. В репозитории доступен только пакет  firefox-ru для firefox 13.0.1.
[Показать] Скрытый текст:
urpmq --list-media active
Main
Main Updates
Contrib
Contrib Updates
Non-free
Non-free Updates
edumandriva_free
edumandriva_non-free

uname -a
Linux localhost.localdomain 2.6.39.4-5.1-generic #1 SMP Wed Jan 4 13:50:55 UTC 20


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 35 ]  На страницу Пред.  1, 2, 3, 4  След.

Часовой пояс: UTC + 3 часа [ Летнее время ]


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB